All Versions
11
Latest Version
Avg Release Cycle
27 days
Latest Release
216 days ago

Changelog History
Page 1

  • v1.0.200

    October 03, 2020
  • v1.0.32 Changes

    February 27, 2018

    ๐Ÿ”– Version 1.0

    Swift cross-platform crypto library derived from [IDZSwiftCommonCrypto]Swift cross-platform crypto library derived from IDZSwiftCommonCrypto.

    IMPORTANT NOTE: This release is NOT entirely source code compatible with previous releases. There are instances where exceptions are thrown now instead of the framework calling fatalError(). This means that there are more recoverable errors in the library than before. The only time that fatalError() is called is to indicate either a programming error or a non-recoverable system error.

    Note: On macOS and iOS, BlueCryptor uses the Apple provided CommonCrypto library. On Linux, it uses libcrypto from the OpenSSL project.

    Prerequisites

    Swift

    • ๐Ÿš€ Swift Open Source swift-4.0.0-RELEASE toolchain ( Minimum REQUIRED for latest release )
    • Swift Open Source swift-5.0-RELEASE toolchain ( Recommended )
    • Swift toolchain included in Xcode Version 10.2 (10E125) or higher.

    ๐ŸŽ macOS

    • macOS 10.11.6 (El Capitan) or higher.
    • Xcode Version 9.0 (9A325) or higher using one of the above toolchains.
    • Xcode Version 10.2 (10E125) or higher using the included toolchain (Recommended).

    iOS

    • iOS 10.0 or higher
    • Xcode Version 9.0 (9A325) or higher using one of the above toolchains.
    • Xcode Version 10.2 (10E125) or higher using the included toolchain (Recommended).

    ๐Ÿง Linux

    • โœ… Ubuntu 16.04 (or 16.10 but only tested on 16.04 and 18.04).
    • One of the Swift Open Source toolchain listed above.
    • OpenSSL is provided by the distribution. Note: 1.0.x, 1.1.x and later releases of OpenSSL are supported.

    ๐Ÿ”„ Changes since 1.0.0

    • ๐Ÿ›  Fixed warnings from Swift 4.1, added build support for 3.1.1 thru 4.1. PR #34.
    • 0๏ธโƒฃ Make Swift 4.1 the default compiler. Issue #35.
    • ๐Ÿ‘Œ Support for Xcode 10 Beta. PR #38.
    • โž• Added Swift 4.2 builds to CI.
    • โž• Added scheme for building iOS version of BlueCryptor and made it shared. Issue #43.
    • Update README to specify libssl-dev as a requirement for building on Linux. Issue #42.
    • โšก๏ธ Minor license update.
    • โšก๏ธ Updates for Xcode 10 to project.
    • ๐Ÿ‘ Swift 4.2 support. PR #46
    • 0๏ธโƒฃ Make Swift 4.2 the default compiler in project.
    • โช Revert (#46) to use OpenSSL module in 4.2 format. PR #47.
    • โšก๏ธ Update recommendations to Swift 4.2 and Xcode 10.
    • โž• Added support for OpenSSL 1.1.x as well as OpenSSL 1.0.x.
    • โž• Added CI support for building with Swift 5. PR #49.
    • โœ‚ Removed requirement of Swift 4.2 to support OpenSSL 1.1.x. OpenSSL 1.1.x is now supported using Swift 4.0, 4.1 and 4.2.
    • โšก๏ธ Update CI support to use Swift 4.2.3. PR #52
    • byteArray utility method will now return an empty array if the input array contains invalid hex digits. Note: This function previously resulted in a fatal error under these circumstances. PR #53. In a future release, this function will throw an exception when encountering invalid hex digits.
    • โšก๏ธ Update to Swift 5.0. PR #54.
    • ๐Ÿง Cleanup warnings on Linux. PR #57, #58.
    • ๐Ÿ›  Fixed warning showing up on Xcode 11. PR #60.
    • โž• Add CI support for Xcode 11.
    • ๐Ÿ›  Fixed some linter warnings, update to Swift 5.1. PR #62
  • v1.0.31

    July 18, 2019
  • v1.0.30

    June 25, 2019
  • v1.0.29

    June 25, 2019
  • v1.0.28

    May 04, 2019
  • v1.0.27

    April 11, 2019
  • v1.0.26

    April 01, 2019
  • v1.0.25

    March 19, 2019
  • v1.0.24

    February 27, 2019